Datapoints/breakpoints do not get activated

Hi there!
I’m in a bit of a trouble. I need to debug a few transformers, and I’m glad you have something to help it with: datapoints.

The tutorial says, that only the grey dot needs to be pressed in order to activate a data point, and it should turn red, thus recording the through-going data.
In my case, it only turns orange (says “Datapoint active, no data”), and after saving the transformer, the dots do not stay orange, they turn back to grey (and also when executing the transformer after the save, it doesn’t function like a datapoint).

I tried to save it from its own page, from an incoming config’s “Entity transformer” modal, and every time it does the same. Without it, the debugging is kinda hard, as I have no information about where exactly the error has happened (outside of knowing the transformer’s id).

(And also: the outgoing PUT request, that actually saves the transformer, does not have any data referencing the datapoint boolean)

Any ideas to fix this?

Best Regards,
Gergő Borsodi

Hi @gerg.borsodi

Welcome to the Alumio forum!

Datapoints can only be used to test the transformer in the entity transformer editor page when you run the tests (click the “Run test” button). Every time you leave/reload the page, the data points will be disabled again.

Could you please let us know whether you debug by running the entity transformer test or by running the whole set of incoming configuration/route?

Hi Gugi!

My bad then: I tried to run these by running the incoming config/whole route; since the error arose in those circumstances, and I don’t know, what is causing it (somwhere there is a bad variable referencing, and I thought I could use this feature to see, where exactly this occurs)

Is there any other possible debug solutions, where if an error occurs, it shows exactly where it has been thrown?

The logs of the incoming configuration job should show you which entity transformer the import failed in. However, it doesn’t show you which exact transformer (prototype) in the entity transformer the error is thrown in.

If it fails when running an incoming configuration, we suggest tracing it manually. You can start by retrieving the data from the HTTP subscriber and passing the result through the entity transformers in the incoming configuration and connected routes until you find where the error is thrown.

If it fails when running a route, you can trace it manually by testing the task’s entity data through the entity transformers in the connected outgoing configuration.

Thank you for your help, much appreciated! :slight_smile:

We are happy to help!

Feel free to create a new topic if you need help or have questions.

1 Like